Hosts shows Configuration "Out of sync"

I have deployed Foreman + one smart proxy in another location.
I am setup Katello, Remote execution, Ansible and SCAP (using ansible). Hosts are registered by activation keys and I only install subscription manger, katello-host-tools and katello-host-tools-tracer on the hosts. No puppet setup on hosts. Currently during my tests the hosts use Default Organization View.

What I see is that after I “Run ansible roles” on the hosts, the configuration status says “No changes” but after a while it goes to “Out of sync”. I can not seem to understand why since I do not change any configurations on either the host or Foreman.

Also wanted to add that if I open the details host page and select Reports (browse host config management reports) it give me status “Skipped” of all of them. I see no errors or warnings, just skipped. Can this can be the reason for the “Out of sync” alert?

this comes from the puppet days when there was an agent running on the managed machines which reported periodically. If the manged machine didn’t report for a while, it was considered out of sync and the same happens with ansible, but by default there is no agent which would report periodically.

When you run ansible, you receive a report, but that report is considered valid only for 30 minutes (by default, can be changed in settings > ansible > ansible report timeout). If you apply roles again, it will start over. Either you can apply roles periodically to get reports and keep the hosts green or you can disable this behavior in settings > ansible > ansible out of sync disabled.

1 Like

Ahh, makes sense. My plan is not to use Foreman for configuration management so I have now set “Puppet out of sync disabled” and “Ansible out of sync disabled” to Yes.
Hopefully that should take care if it.

Thanks, Paul

Hmm, seems setting “Puppet out of sync disabled” and “Ansible out of sync disabled” to Yes.only helped for a while. Unsure if it stopped working when I upgraded to latest version of Foreman but the “Out of sync” is back. I can run apply the roles again and it goes away for a while but then it come back. Will try and set the “Ansible report timeout” and “Puppet interval” to 9999999.

OK the change of “Ansible report timeout” and “Puppet interval” to 9999999.made no change. Sorta annoying to have to Configuration “Out of sync” on all hosts and can not get rid of it, hiding any other alerts that can be good to see from the web page, like last execution, errata and traces