How to display operating system field for hosts running CentOS

My Red Hat Enterprise Linux systems do show the current major and minor release, but this field is blank when host is CentOS. I am not using Katello as a Puppet master or for provisioning.

Thanks in advance for any advice.

This should be fixed in Katello 3.14 - Bug #26914: Content Hosts OS no populated with centos 7 - Katello - Foreman

If it’s especially problematic we can probably port it to 3.13.1 (3.13.0 will be GA soon)

@Jonathon_Turel thanks for the update. Not a rush since it has never worked for me going back to when I first ran Red Hat Satellite 6 in 2016. Just like that it works on our Foreman environment that we use to control Puppet for our systems. I thought it was something that I wasn’t doing right.

1 Like

Technically CentOS 7 doesn’t really have minor versions it supports. That means you can’t install a CentOS 7.6 now that 7.7 is out. That kind of makes me wonder why you care. Is it for reporting applicable updates?

It is more to visualize what OS is installed when looking at the host list. I understand the minor release part of CentOS, but when managing over 700 systems in Katello across multiple locations having the OS name (CentOS/RHEL) and at least major version would be a nice to have. Official Red Hat versions have always worked as I would expect.

That makes sense though I’d consider the full 7.7.1908 string for that.

Yes, absolutely. Currently is doesn’t show anything for CentOS systems in the operating system column. For now, I just know if it is blank then it’s CentOS.

I’m glad to hear this is going to be fixed. Will this have the side effect of fixing remote execution on CentOS7 and Oracle Linux 6/7 clients using job templates? (which currently fails with errors such as “ERF18-8334 [InputTemplateRenderer::RenderError]: Unsupported or no operating system found for this host.”