I don't want to use PXELinux default local boot


I have taken a clone of the template “PXELinux default local boot” and have a new named file, which I have made changes to “PXELinux mysys local boot”. I have associated this new template to the OS and the host group environment. The machine provisions correctly, but still used the same “PXELinux default local boot” file.

Expected outcome:

After provision and reboot, the system should use the new template?

Foreman and Proxy versions:


Foreman and Proxy plugin versions:

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]

I believe that kind of template, the local boot template, is associated globally by going to Settings -> Provisioning -> “Local boot PXELinux template”

1 Like