I have synced the Oracle Linux 8 Repos

I have the correct .ipxe cfg file I think

While I’m trying to rebuild the config from the foreman UI as you suggested it gives an error saying

Those files look correct to me at a glance.
If you watch the PXE boot process on the hosts console, are the files mentioned here (oeaclelinux8--<initrd/vmlinuz.img> the files that are actually downloaded or is it downloading something else? (like centos7--*)

Hello @areyus while PXE boot is happening it is not downloading the file any reason why it is happening

This is where our init.rd and vmlinuz file is present as you suggested I have copied the files to /var/lib/tftpboot/boot and just to avoid confusion I have renamed it to oraclelinux8-initrd.img and same for vmlinuz.img

The error iPXE gives you indicates you are trying to boot using a protocol not supported by your iPXE rom (in this case: HTTPS). The iPXE banner tells you it supports HTTP (among others) but not HTTPS.
Try switching the URL in your installation image to http instead, then it should work.

edit: You might need to cancle and restart the build process for the host to regenerate the ipxe file.

This looks like the issue reported here.

I made the change in the Installation media to http came up with the following error

According to the linked page you have a problem with the DNS resolution. doublecheck your hostname in the URL and maybe also try FQDN instead of shortname.

Sorry to ask not following up with you where do I need to check as this host is getting provision using the Centos 7

I tried using the IP address in the URL but the results were different

No such file or directory

Well, that’s at least a step in the right direction I guess.
Check in /var/www/html/ if the path to the vmlinuz file is correct and if it is readable by the apache user. The error message indicates either the path is wrong or apache can not access the file (either the file or some directory along the way can not be accessed by apache)

Hello @areyus Is it possible for you to have a call set up whenever you are available struggling a lot here and need to upgrade the OL 8 the organization demands it
please let me know how can I reach out to you or vice versa

Hello community I tried the OL 7 OS and the good part is shows the bootable format and getting the synced content so maybe we would be switching to OL 7 not sure why OL 8 can’t get the synced content but thanks to @areyus @jeremylenz for your support