Include Host Within Foreman Reporting Disabled

Hey everyone, I have kind of a unique problem here. I am running two
instances of Foreman completely independent of each other. Both are running
1.6.3. On my Development instance when I provision a new host from within
Foreman or add a new host through Puppet to Foreman the check box to
include the host within Foreman reporting (on the Additional Information
Tab) is checked by default. On my production instance, under the same
scenarios, that box is not checked by default (but it use to be as I
remember). I've searched and tried to figure this out for over a day and
cannot seem to make any headway. Does anyone know what might have changed
or how I can get that box to be checked by default again? What is really
strange too is that newly provisioned or added hosts in my production
instance (box not checked by default) show up on the "All Hosts" page as
"Alerts Disabled" but on the dashboard they do not show up under "Hosts
with alerts disabled" and if I search status.enabled = false they don't
show up there either. I have to edit the host and check the box, then
reedit the host and uncheck the box and then it will show up as having
alerts disabled.

The main thing here is I would very much like to have alerts enabled by
default in my production Foreman instance. I will be updating to 1.7 soon
and would like to have this resolved before then. . . unless updating to
1.7 might fix this.

Thanks in advance for any help!