I'm trying to the latest version of Foreman via RPM, and I'm
getting the following error message:
sudo rpm -Uvh /home/hmedina/foreman-0.1.6-2.noarch.rpm
error: Failed dependencies:
rubygem(rake) >= 0.8.3 is needed by foreman-0.1.6-2.noarch
rubygem(sqlite3-ruby) is needed by foreman-0.1.6-2.noarch
But I have these GEMs installed:
*** LOCAL GEMS ***
Are there any switches to the command that I'm missing? I'm running
CentOS 5.5, ruby 1.8.6 and gem 1.3.7.
Thanks in advance,
> I'm trying to the latest version of Foreman via RPM, and I'm
> getting the following error message:
> sudo rpm -Uvh /home/hmedina/foreman-0.1.6-2.noarch.rpm
> error: Failed dependencies:
> rubygem(rake) >= 0.8.3 is needed by foreman-0.1.6-2.noarch
> rubygem(sqlite3-ruby) is needed by foreman-0.1.6-2.noarch
> But I have these GEMs installed:
> *** LOCAL GEMS ***
> actionmailer (2.3.5)
> actionpack (2.3.5)
> activerecord (2.3.5)
> activeresource (2.3.5)
> activesupport (2.3.5)
> fastthread (1.0.7)
> mysql (2.7)
> net-sftp (2.0.4)
> net-ssh (2.0.23)
> net-ssh-gateway (1.0.1)
> net-ssh-multi (1.0.1)
> passenger (2.2.11)
> rack (1.0.1)
> rails (2.3.5)
> rake (0.8.7)
> rubygems-update (1.3.7)
> sqlite3-ruby (1.2.5)
> Are there any switches to the command that I'm missing? I'm running
> CentOS 5.5, ruby 1.8.6 and gem 1.3.7.
> Thanks in advance,
It's complaining about RPM dependencies, so installing via 'gem' won't
resolve them. You probably want to configure your system to use EPEL:
http://fedoraproject.org/wiki/EPEL to install the correct rpms.
Both of those gems are packaged as rpms for EL5 in EPEL (rubygem-rake
On Wed, Dec 8, 2010 at 7:33 PM, CraftyTech wrote:
You received this message because you are subscribed to the Google Groups “Foreman users” group.
To post to this group, send email to firstname.lastname@example.org.
To unsubscribe from this group, send email to email@example.com.
For more options, visit this group at http://groups.google.com/group/foreman-users?hl=en.