Internal Server Error with foreman-proxy

Hello everyone! I’m experiencing an Internal Server Error with foreman-proxy despite it otherwise having setup just fine and displaying as operating normally via the command, service foreman-proxy status. You can view a screenshot of the problem by clicking the link [ 1 ] below.

[ 1 ] -


I encounter the issue, uninitialized constant Rack::Handler::WEBrick::RACK_VERSION Did you mean? RUBY_VERSION, when trying to access the proxy via the web. It worked okay the very first time I accessed it but thereafter, it failed. Otherwise SSL seems to be operating normally and without any warnings.

Foreman and Proxy versions:

Foreman is v1.23.0~rc1-1 and foreman-proxy seems to also be v1.23.0~rc1-1, both according to apt-cache. The operating system is the latest version of Ubuntu 18.04 LTS under a KVM VPS.

You can view an excerpt of my /var/log/foreman-proxy/proxy.log by going here:

Thank you and we’d appreciate any and all help!

I’ve solved the issue, thanks everyone. It was to do with there being two differing versions of rake, and I had to uninstall one of them with gem uninstall :slight_smile: