Issues kickstarting RHEL9

I’m playing around with the RHEL 9 beta and trying to kickstart it from a Satellite server (no issue installing from ISO), however during the downloading of packages it encounters a fatal error where it says:

Failed to download the following packages: Cannot download Packages/shim-x64-15-16.el8.x86_64.rpm: All mirrors were tried

If I look in the logs within anaconda I see this message in /tmp/packaging.log:

WRN packaging: Failed to download ‘shim-x64-15-16.el8.x86_64.rpm’: 3 - Interrupted by header callback: Server reports Content-Length: 682476 but expected size is: 683844

It’s weird to me that the package has an el8 in it, but it is a beta. Wondering if anyone else has encountered something like this or has any idea why it might be happening

At @lzap’s advice I attempted to resync the kickstart repos using an immediate download policy as opposed to an on-demand one. That initially returned a checksum error (I should’ve taken a screenshot, but didn’t) but after doing a validate content on the repos they synced successfully with the immediate policy. However, the error from above with the Content-Length is still present

Hello and welcome!

I am kicking off RHEL9 Beta sync and I will test this on my Satellite 6.10.

What’s your Satellite version by the way?

1 Like

Hmmm I don’t see RHEL 9 Beta repos on my subscription:

I need to ask the content team what is going on.

I had to use Red Hat Beta Access subscription instead of my Employee one. Trying to reproduce now.

So I have tested this on Satellite 6.10.

Few changes in provisioning templates are required, this has been done already in the upstream (so Satellite 7.0 will have this):

  • Change ks= to inst.ks= in PXE template
  • Remove sendmac and ks.sendmac and only use inst.ks.sendmac in PXE template
  • Remove redhat-lsb-core in kickstart

I filed a 6.10 BZ I think it would be useful to backport these changes into 6.10: Invalid Bug ID

Anyway, I tested this in a libvirt VM and it worked, no downloading issues. However, I noticed you had problems with shim package which means you are installing perhaps a EFI host? So I tried to install it and DNF is unable to find such package. What is striking me is also it has an incorrect package tag - I would expect it to be el9 and not el8: shim-x64-15-16.el8.x86_64.

It smells like some problem with the repo upstream, it looks like the package is in the metadata but now present in the repo itself. I am going to reinstall the host and subscribe it directly to the portal without Satellite to see if it works that way.

To recap:

I have created a “Red Hat Beta Access” manifest, imported into Satellite 6.10, enabled and synced RHEL 9 Beta and tried to kickstarted it. Works fine for BIOS, however, when I attempt to install package shim, Pulp gives 404. The package is present in the metadata, however, it is not present in the Packages/ subdirectory which ends with 404.

This looks like a bug, package shim is actually provided by something else, likely shim-x64 and that package is upstream in version shim-x64-15-16.el8.x86_64. That is incorrect tag for RHEL9, however, this is likely due to signing at Microsoft - old build of shim was used for the beta version.

I tried to register directly to Red Hat portal and from there, I can install both shim and shim-x64 packages just fine:

# dnf info shim-x64
Updating Subscription Management repositories.
Last metadata expiration check: 0:04:39 ago on Mon 17 Jan 2022 12:59:55 PM UTC.
Installed Packages
Name         : shim-x64
Version      : 15
Release      : 16.el8
Architecture : x86_64
Size         : 5.0 M
Source       : shim-15-16.el8.src.rpm
Repository   : @System
From repo    : rhel-9-for-x86_64-baseos-beta-rpms
Summary      : First-stage UEFI bootloader
URL          :
License      : BSD
Description  : Initial UEFI bootloader that handles chaining to a trusted full
             : bootloader under secure boot environments. This package contains the
             : version signed by the UEFI signing service.

Just for the record, I downloaded the package from the CDN directly to check its size:

[root@mac525400e35fa8 ~]# dnf download shim-x64
Updating Subscription Management repositories.
Last metadata expiration check: 0:06:53 ago on Mon 17 Jan 2022 12:59:55 PM UTC.
shim-x64-15-16.el8.x86_64.rpm                                                                                                  1.4 MB/s | 666 kB     00:00

[root@mac525400e35fa8 ~]# ll shim-x64-15-16.el8.x86_64.rpm
-rw-r--r--. 1 root root 682476 Jan 17 13:06 shim-x64-15-16.el8.x86_64.rpm

If you can install a BIOS system which does not require shim for installation and then you can try to install the package manually, that would be interesting to see how it ends up. I need to hand this over to Pulp/Katello guys for further investigation, but for me it works fine. Googling suggest that these kind of errors show up when something is wrong with YUM metadata, “yum clean all” is usually the solution, perhaps something similar is for Pulp. @katello

Yes, I was doing this on an EFI host. I switched to using BIOS and the shim error went away, however I got the same error on a different package: python3-systemd-234-18.el9.x86_64.rpm. For this one it says it has a reported content-length of 96338 and an expected content-length of 95778

Forgot to answer your version question, running Satellite 6.10

I brought the problem on our internal mailing list, hopefully someone from Pulp can enlighten me on these errors. Since it works for me, I think this is some data corruption error.

Are you on Pulp2 or Pulp3? Satellite 6.10 can do both I think.

1 Like

Pulp3, thanks again for digging into this

So I got a word from Katello devs asking me to open a BZ against Satellite and possibly also issue at Issues · pulp/pulp_rpm · GitHub - they want to take a look.

I am afraid I can’t help you further as content management is not my thing and it worked for me. Thanks.

No worries, this is the type of thing I was expecting with testing out the RHEL 9 beta. Let me know if there’s anything I can do to help out the Katello devs

If you can drop links here so I can subscribe to them, I am interested, thanks.

I submitted

2042730 – Issues kickstarting RHEL 9 beta and
Issues kickstarting RHEL 9 beta · Issue #2365 · pulp/pulp_rpm · GitHub

1 Like