Issues with qpid-proton due to 0.35.0 release in EPEL

This is my output:

# yum install katello-agent
--> Running transaction check
---> Package katello-agent.noarch 0:3.5.4-1.el7 will be installed
--> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent-3.5.4-1.el7.noarch
--> Running transaction check
---> Package python-gofer-proton.noarch 0:2.12.5-3.el7 will be installed
--> Processing Dependency: python-qpid-proton >= 0.9-5 for package: python-gofer-proton-2.12.5-3.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-gofer-proton-2.12.5-3.el7.noarch (Katello_agent_3_18_RHEL_7)
           Requires: python-qpid-proton >= 0.9-5
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

Error: Package: python-gofer-proton-2.12.5-3.el7.noarch (Katello_agent_3_18_RHEL_7)
           Requires: python-qpid-proton >= 0.9-5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I figured I’d leave some notes on what worked for me if you find this thread in a similar situation as I found myself. I was trying to upgrade a long-neglected install standing at Foreman 1.23.2 and Katello 3.13.4. Very unsupported and no hope that docs would be updated with this detail as they are now archived as PDFs. Following the suggestion to update through each released version, one must do yum update (often!) but still get around the rpm dependencies that katello has with quid-proton 0.35.

Using the copr source mentioned above, I installed the 0.34 of quid-proton-c and python2-qpid-proton.
yum install -y
yum install -y

I then ran updates following @rgp suggestion of using
yum update -x qpid-proton-c,qpid-dispatch-router

I’ve had successful updates through 1.24, 1.25, 2.0. Still working my way to 3.0.

Full disclosure, I’m no authority on if this breaks or harms the install or operation. I’m simply parsing these details and trying to get through an update process on unsupported versions that are still affected by this EPEL change but won’t likely get a fix.

Hey everyone,

I’m perfectly fine with removing the katello-agent and qpid packages on hosts as we use remote execution. But trying to remove the qpid packages on the foreman server references dependencies on katello packages. We are on Foreman 2.3.5 and Katello 3.18.3

@milanzelenka it sounds like you ran into this issue as well. Did you find a workaround?

@ehelms @ekohl have you got any news about this issue?


1 Like