Katello 3.0.1 installation fails - Crane: Failed to configure CA certificate chain!

Hi

I am trying to install Katello 3.0.1. I am using my own certificates, so I
do like this:

sudo foreman-installer --scenario katello
–certs-server-cert="/etc/pki/tls/certs/katello.local.crt"
–certs-server-cert-req="/etc/pki/tls/csr/katello.local.csr"
–certs-server-key="/etc/pki/tls/private/katello.local.key"
–certs-server-ca-cert="/etc/pki/tls/certs/CompanyInternalCA.crt"

Bu installation fails with:

[ERROR 2016-06-23 13:13:36 verbose] /Stage[main]/Apache::Service/Service[
httpd]/ensure: change from stopped to running failed: Could not start
Service[httpd]: Execution of '/usr/share/katello-installer-base/modules/service_wait/bin/service-wait
start httpd' returned 1: Redirecting to /bin/systemctl start httpd.service

sudo cat /var/log/httpd/error_log
[Thu Jun 23 13:15:54.289451 2016] [ssl:emerg] [pid 10568] AH02311: Fatal
error initialising mod_ssl, exiting. See /var/log/httpd/crane_error_ssl.log
for more information

sudo cat /var/log/httpd/crane_error_ssl.log
[Thu Jun 23 13:13:36.150962 2016] [ssl:emerg] [pid 10139] AH01903: Failed
to configure CA certificate chain!
[Thu Jun 23 13:15:54.289440 2016] [ssl:emerg] [pid 10568] AH01903: Failed
to configure CA certificate chain!

In Apache crone config file I see that it is configured with default SSL
certs, not my custom
sudo cat /etc/httpd/conf.d/03-crane.conf

··· **************************** Vhost template in module puppetlabs-apache Managed by Puppet **************************** ServerName katello.local


SSL directives
SSLEngine on
SSLCertificateFile "/etc/pki/katello/certs/katello-apache.crt"
SSLCertificateKeyFile "/etc/pki/katello/private/katello-apache.key"
SSLCertificateChainFile "/etc/pki/katello/certs/katello-default-ca.crt"
SSLCACertificatePath "/etc/pki/tls/certs"
SSLCACertificateFile "/etc/pki/katello/certs/katello-default-ca.crt"
SSLVerifyClient optional
SSLVerifyDepth 3
SSLOptions +StdEnvVars +ExportCertData +FakeBasicAuth
SSL Proxy directives
SSLProxyEngine On
WSGIScriptAlias / “/usr/share/crane/crane.wsgi”

I checked with katello-certs-check tool and my certs are ok.

I also created issue: Bug #15507: Katello 3.0.1 installation fails - Crane: Failed to configure CA certificate chain! - Katello - Foreman