Katello 3.16.1-1.el7 subscription-manager doesn't create rhsm repos for ubuntu

same for me


details page

I think it may be here
Started PUT “/rhsm/consumers/d475fec0-3a78-4ce5-8bc9-b588f96015ba” for 127.0.0.1 at 2020-10-21 09:06:45 +1100
the put I think should be to the clients address

nope just registered a Centos 7 system and it uses 127.0.0.1

lets connect and screen share

sorry can’t do due to to security policy.

test_log_centos.log (76.8 KB) test_log_ubuntu.log (36.7 KB)

I’ve added 2 debug logfiles with subscription-manager repos on both Ubuntu 18 and Centos 7 the difference occurs on line 61 and a PUT is never sent on Ubuntu but it is on Centos. There is clearly a bug in Katello

I suspect it is a pulp 2 issue on the smart proxy - I thought it was all pulp3

The Debian/Ubuntu integration for Pulp 3 is not quite done:

1 Like

Can you show me your debian repository settings? Did you set a architecture?

This is the get GET “/rhsm/consumers/fdf45436-0d12-479f-abd7-682a87af5bb8” It all looks OK to me - just not pushing it back

Can you try to use a repository without setting the architecture? (= all) Can this repo used on the client side?

Yes that works but won’t it break the repository sync

root@syd01ddev06:~# subscription-manager repos
±---------------------------------------------------------+
Available Repositories in /etc/yum.repos.d/redhat.repo
±---------------------------------------------------------+
Repo ID: Default_Organization_ub18_repos_bionic
Repo Name: bionic
Repo URL: https://bss01.orch.vocus.net/pulp/deb/Default_Organization/stable/ub1
8_content/custom/ub18_repos/bionic
Enabled: 1

So, you say it works from katello till host which is managed by sub-man? And exactly this, didn’t work before when setting the architecture?

yes once I removed architecture from the repo config in foreman subscription-manager refresh then subscription-manager repos on the client updated rhsm.sources on the client fo the only repo I changed - the others in the content which had their architecture set did not populate .rhsm.sources on the client

argh. I’m very sorry. We worked on a feature which is “half-in”. The change affected candlepin, katello and sub-man but the sub-man change is not merged right now. Therefore it doesn’t work completely and we full into this issue.

I guess, it will work when reverting:

We (= I) will work on this soon - hopefully tomorrow.

The overall feature idea was, to only make repos available on the client side, which are supported. Like, if the repo supports i386 and arm64 but the client only supports arm64, it should only provide arm64 repositories.

My bad - I’m sorry.

2 Likes

At least this confirms it is not my config. Thanks for all your work on the deb parts of foreman/katello - If you need any testing let me know. I also appreciate the security errata changes that are in the pipeline. It will really be a game changer for us.

4 Likes

@stephenc I need some help with pulp3 docker , I see you have some docker repo , can you please help me in it ?

Foreman 2.2 and katello 3.16 docker pull