Katello 3.5.1 upgrade failed

I was trying to upgrade katello to the latest release 3.5.1. I followed official upgrade guide and after yum update system returned me an error “package RPM is not signed”. I installed them, anyway, with --no-gpgcheck. I Run the installer as foreman-installer --scenario katello --upgrade
at the end of installation the error:

Upgrade Step: correct_puppet_environments (this may take a while) …
/usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
/usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
rake aborted!
Not all the services have been started. Check the status report above and try again.
/opt/theforeman/tfm/root/usr/share/gems/gems/katello- `block (2 levels) in <top (required)>'
Tasks: TOP => katello:correct_puppet_environments => katello:check_ping
(See full trace by running task with --trace)
{:pulp=>{:status=>“ok”, :duration_ms=>“36”},
:pulp_auth=>{:status=>“ok”, :duration_ms=>“27”},
:candlepin=>{:status=>“ok”, :duration_ms=>“14”},
:candlepin_auth=>{:status=>“ok”, :duration_ms=>“24”},
“some executors are not responding, check /foreman_tasks/dynflow/status”}},
foreman-rake katello:correct_puppet_environments COMMIT=true failed! Check the output for error!
Upgrade step correct_puppet_environments failed. Check logs for more information.

Anyone could help me?

To be honest, I don’t know your exact error. But I do find sometimes that just running the --upgrade command a second time will make it work. Did you try that?

I reinstalled packages and tried again --upgrade and now it works!