Katello disable https

Problem: I would like to setup katello behind F5, for this I will be allowing connections from specific ips to my host and use https in the F5, however when I install katello with the following:

foreman-installer --scenario katello --foreman-gpgcheck=false --foreman-ssl=false --foreman-unattended-url=http://katello.domain.tld --foreman-servername=katello.domain.tld

It complains that it is unable to connect through https (of course it cant because I just disabled it)

/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[katello01.domain.tld]: Could not evaluate: Exception Failed to open TCP connection to katello01.domain.tld:443 (Connection refused - connect(2) for "katello01.domain.tld" port 443) in get request to: https://katello01.domain.tld/api/v2/smart_proxies?search=name=%22katello01.domain.tld%22

Expected outcome: I’m expecting to either disable https on the node side receiving the connections from the F5 or disabling the forced redirect from http to https

Foreman and Proxy versions: 2.0

Foreman and Proxy plugin versions: 2.0

Distribution and version: CentOS 7.8

Other relevant data:

Why would you disable https? Just install the cert on your F5. We do that and have no issues. All our internal traffic must be encrypted.