Katello-nightly installation (2019-05-21) leaves pulp in errored state


#1

This is a followup on the issue
https://community.theforeman.org/t/katello-nightly-installation-2019-05-10-leaves-pulp-in-errored-state/13882/3
which got automatically closed since i did not manage to respond to it in time.

@Marek_Hulan asked:

I suppose our katello nightly job does not fail on this - https://ci.theforeman.org/job/katello-nightly-rpm-pipeline/

Do you by any chance install the plugin pulp_ostree later, after the installer has been run? Do you use any DB snapshots? Could you link the steps that are running the installation? If we can’t reproduce in our job, we need to find out, how your job differs.

  • Yes, we install katello without enabling it, we run a standalone foreman-installer --enable-ostree later in the process:

here’s how we install it:
foreman-installer --scenario katello -v --foreman-initial-admin-password="changeme" --disable-system-checks --foreman-proxy-dns="true" --foreman-proxy-dns-interface="eth0" --foreman-proxy-dns-zone="satqe.foo.bar.com" --foreman-proxy-dhcp="true" --foreman-proxy-dhcp-interface="eth0" --foreman-proxy-tftp="true" --foreman-proxy-tftp-servername="qe-foreman-rhel7.satqe.foo.bar.com" --foreman-proxy-register-in-foreman="true" --foreman-proxy-puppetca="true" --foreman-proxy-puppet="true" --foreman-proxy-dhcp-range="10.8.213.10 10.8.213.250" --foreman-proxy-dhcp-gateway="10.8.213.254" --foreman-proxy-dns-reverse="213.8.10.in-addr.arpa" --katello-proxy-url="http://ginger.foo.bar.com" --katello-proxy-port="3128" --katello-proxy-username="admin" --katello-proxy-password="redhat" --enable-foreman-plugin-remote-execution --enable-foreman-proxy-plugin-remote-execution-ssh --enable-foreman-plugin-discovery --enable-foreman-proxy-plugin-discovery --enable-foreman-plugin-openscap --enable-foreman-proxy-plugin-openscap --enable-foreman-plugin-ansible --enable-foreman-proxy-plugin-ansible --foreman-proxy-dns-forwarders="10.8.104.51" --foreman-proxy-dns-forwarders="10.11.5.19" --foreman-proxy-dns-forwarders="10.10.160.2" --foreman-proxy-dns-forwarders="10.5.30.160"

next, we perform the following tasks:
hammer -u admin -p changeme settings set --name=check_services_before_actions --value=false [10.8.213.1] out: Setting [check_services_before_actions] updated to []. - this might be relevant to issues we experience.

here are the steps we take next:
`

katello-service restart

yum -y install puppet-foreman_scap_client

foreman-rake foreman_openscap:bulk_upload:default

foreman-installer --scenario katello --katello-enable-ostree=true

… (couple of non-related tasks, liek setting up libvirt keys, foreman discovery,…)

sed -i -e “0,/addr: 0.0.0.0/s/addr: 0.0.0.0/addr: ::/” /etc/qpid-dispatch/qdrouterd.conf

systemctl restart qdrouterd

installing coverage python module using pip

`
Then we stop the katello services and shut down the VM using virsh command.

I’ll try to fiddle with the machine a little and try to find out which step causes this exactly.


#2

ok, it seems we figured it out, the issue is in foreman-installer:
https://projects.theforeman.org/issues/26905


closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.