katello-nightly-rpm-pipeline 719 failed

Katello nightly pipeline failed:

https://ci.theforeman.org/job/katello-nightly-rpm-pipeline/719/

foreman-pipeline-katello-nightly-centos7-install (failed)
foreman-pipeline-katello-nightly-centos7-upgrade (failed)

I chatted with pulp team and it appears that the root of the issue was
this change: https://github.com/theforeman/puppet-pulpcore/commit/b3b7c133c513dd2c30b00a81e64b2bb33ca92397

I opened an issue here: https://pulp.plan.io/issues/7698

@ekohl should we revert that change for a bit? To get the fix in, we’d
have to request a 3.6.z fix (and a 3.7.z fix).

Justin

When I tested https://github.com/theforeman/puppet-pulpcore/pull/105 I did not hit this failure. With that being so close, I think we could try to fix it via that merge.

Are you sure you tested with b3b7c133c513dd2c30b00a81e64b2bb33ca92397 applied?

We could just revert the ‘WorkingDir=~’ part, the rest should be fine. The change itself was good, it just exposed a bug in pulp3.

I did confirm locally that setting WorkingDirectory=/var/run/pulpcore-worker-%i/ in the systemd unit file for the workers resolved the issue.

Yes, that is part of it. I do wonder if somehow this commit didn’t make it in:

Looks like I relied on a feature that’s not in EL7’s systemd. We’re getting to the point where EL7 becomes a pain to use again due to its age :frowning:

I can confirm its not there in
foreman-installer-2.3.0-0.2.develop.20201009031222git20fc903.el7.noarch

which is what is installed.

let me double check if it fixes the problem

Actually a yum update brought it in, so i guess it just took a while to propagate into staging? It looks like katello-nightly-rpm-pipeline 720 failed actually had this change and got a lot further. It failed on the semi-transient proxy sync error :frowning: I will re-kick it

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.