Katello-proxy-url not recognized during install

I am trying to install the newer version of foreman/katello and I am running into an issue when I try to supply the proxy URL/port during install. This has worked with the older versions of foreman previously. Was this option replaced with something else, or am I missing something?

[root@foreman tmp]# /usr/sbin/foreman-installer --scenario katello --katello-proxy-url http://proxy.example.com --katello-proxy-port 80 --tuning medium
ERROR: Unrecognised option ‘–katello-proxy-url’

See: 'foreman-installer --help'

Expected outcome:
Proxy and port gets set and installation goes thru without errors. The last I tried this was with katello 3.13 and foreman 1.23

Foreman and Proxy versions:
Foreman: 2.0
Katello: 3.15


The option was replaced, its not longer configurable as part of the installer.

Instead you can create a proxy within the UI under:

Infrastructure > HTTP Proxies

If you want to set a global content proxy, you can do that on the:
Administer > Settings > Content

page, look for ‘global content proxy’. Then on each repository you can configure it to use, 1) the global default, a specific proxy, or no proxy at all. This was a change to give more granular control over proxy configuration.

Both creating the http proxy and configuring the global setting can be done from hammer.

Got it. Thanks for the update, Justin!

Since I am using a script for installing and configuring foreman, the hammer commands is what I ended up using and it works as expected. Thanks a lot.

May be this document needs to be updated to reflect that http_proxy can no longer be set/created during install by these options.


Hah, i looked for those docs before replying and couldn’t find them, but they were right in front of me.

I filed an issue here: Bug #29638: update http proxies documentation for 3.15 - Katello - Foreman

it looks like the new method is documented, but the old is not! so def. needs updating.