Katello: some products/repositories are not visible on client system after registration but visible under hosts/*hostname*/repositorie sets

some products/repositories are not visible on client system after registration but visible under hosts/repositorie sets
I have created (as often before) a content view with some repositories for the katello client for different OS versions + a content view for the OS itself + a ccv for both. After that I have created a registration key with this ccv (published and promoted). Within the activation key I have selected the OS repository sets and the related repository from the katello client cv. After registration of the client with this activation key, the OS repositories are all there but the katello client repository not :frowning: . subscription-manager refresh does not change anything and the product is not visible on the client via subscription-manager but if I look in foreman → ‘content host’ → hostname, I can see the product / repository as existing/enabled

Expected outcome:
All under hosts/hostname/content visible and enabled repositories are registered / available on client after registration

client system is on SLES15SP3

Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Katello 4.7
Distribution and version:
rocky linux 8
Other relevant data:

Is this a Red Hat repo or a custom repository?

The repository sets screen will show the content overrides you have for the host, but doesn’t necessarily reflect exactly what will be available to the host. There may be OS version or arch restrictions.

If it’s a custom repo, check if “Restrict to OS Version” or “Restrict to Architecture” are set for the repo.

Also, if you’re using a content view / LCE for this host, make sure the repo is listed even when you “Limit to Environment.”


sorry for the delay: this is a normal yum repository (from SUSE). I have checked the activation key as well with the same result (product is there but no .repo created).
Note: I had added the new product to an existing contentView (just that what was not visible afterwards). published, promoted etc and adjusted an existing activation key.
After I had built a completely new Lifecyle Environment chain / Content View / Composite Content View / Activation key, it worked now
But it can’t be the solution to rebuild everything with every new product …
Best regards

Is your composite content view set to auto publish? If not, you’d have to publish both the CV and CCV before the host would see it.

Also, is the CCV set to always use the latest version of the CV?

Also try subscription-manager repos or dnf upload-profile on the host; this should update its available repositories.

shure … I have done all that (ccv autopublish and latest version, subscription-manager repos, subscription-manager unsubscribe + clean + subscribe … all that and more) the only way was “rebuild everything” I new katello now since severall years and this behaviour is new

hmm… See if this could also apply: CentOS 7 client does not see BaseOS repositories - #4 by jeremylenz

Since you’re on Katello 4.7, you can try running foreman-rake katello:check_candlepin_content and see what it tells you.