Kickstart getting failed

Problem: Kickstart is getting failed

Expected outcome:

Foreman and Proxy versions: 1.15.2

Foreman and Proxy plugin versions:
Foreman tasks: 0.9.4
foreman_docker 3.2.1
foreman_remote_execution 1.3.3
foreman_setup 5.0.0

Other relevant data:
I’m trying to provision a system from Foreman, tried by providing static IP and DHCP
It does take IP from DHCP and static and proceed further, then it stops at : Operating System not found error.

I’m very new to this, could you please help me out with this?

Hi @vickysingh99,

Thanks for joining the community!

Regarding your issue, would it be possible to state what you have tried so far and what you are trying to accomplish exactly? From what I can tell it could be anything at this point :slight_smile:

Also, if you’re new I’d recommend using the latest greatest version of Foreman (I see you are using 1.15.2 which I consider ancient by now).

Don’t forget to enable DHCP & TFTP as well as DNS services in the foreman-installer :slight_smile: (although this is vague help, I can help better when my first question gets answered :slight_smile: )

Kind regards!

Thank you for your suggestions!

Well, this is we received as legacy and it was working till few days back when we were demonstrated about it’s functioning.
We have tries to change the templates and restarting the services as well, but nothing seems to work so far.
We will upgrade it now and see if it works. Can you guide me to some documentation where I can get some help about it’s setup and configuration.

Hi @vickysingh99,

The best documentation imo is the official documentation:

As for your upgrade, you’ll need to do it step-by-step, meaning from 1.15 to 1.16 to 1.17 to … etc all the way up to the latest greatest; this because multi-step version upgrades are not supported (or recommended to try).

Links to the upgrade manual:

Replace the “1.22” in the URL with 1.16 and follow the instructions there; repeat that for 1.17, 1.18, … and so on.

Do be warned that this is not for the faint of heart as it will probably take some time to do so, with some caveats in-between each upgrade.

However, we’re here to try and help if you would encounter such a situation.
Best to snapshot between each upgrade, so you easily return to your previous situation in case something goes wrong.

(regarding your original problem; looking at these high-level error symptoms, by guess would be that your TFTP service is unreachable; you could check out your DHCP config and see if you can reach the configured TFTP service)

Kind regards and the best of luck!