Libvirt video card

Hi,

Today I was playing with Foreman and Libvirt and when creating a VM I could see the following warning message in the log:

qemu-kvm: -device cirrus-vga,id=video0,bus=pci.0,addr=0x2: warning: 'cirrus-vga' is deprecated, please use a different VGA card instead

I know it’s not a big deal, but I was wondering if cirrus wouldn’t be removed in a future version of qemu-kvm. In my environment I changed the following lines:

<video>
  <model type='cirrus' vram='9216' heads='1'/>
</video>

By:

<video>
  <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
</video>

in /opt/theforeman/tfm/root/usr/share/gems/gems/fog-libvirt-0.7.0/lib/fog/libvirt/models/compute/templates/server.xml.erb

Do you think that it could be interesting to update the template?

Quentin

I think you should take this to the relevant project:

I’ve just done that! Thanks :slight_smile: