Need Help Installing Katello onto eith OEL 7.x or OEL 8.x server

Problem:
Ive been trying to install Katello onto either an OEL 7.x or OEL 8.x server and for the life of me cant get it to install.

Constant dependency issues , I follow the guides and just never seem to be able to get it to install.
I have installed to CentOS fine but have the requirement of it being installed on OEL.

Can anyone who has successfully deployed it on OEL point me in the right direction or point me to a howto of someone that has successfully deployed to OEL.

Hey @loosepin313.

Welcome to the community !

Which version of Katello are you using?
Which guide are you using? Where in the process are you getting stuck?
What errors are you getting?

Can you provide as much detail as you can to help troubleshoot your issue.

Thanks!

I have built an OEL 7.9 VM with a next next next base iso install nothing special.
I have disabled firewall.
I have disabled selinux.
[root@katello-oel ~]# cat /etc/oracle-release
Oracle Linux Server release 7.9

I have been using the katello install documentation and targeting v3.15
https://theforeman.org/plugins/katello/3.15/index.html

I’ve tried both of the operating system methods Red Hat Enterprise Linux 7 as OEL is closest to this and also Enterprise Linux 7 (CentOS etc)

For the RHEL type install I tried to match the equivalents from oracle
yum -y install oracle-epel-release-el7
yum-config-manager --enable ol7_latest ol7_optional_latest software_collections
yum -y install yum-utils scl-utils
yum -y localinstall https://yum.theforeman.org/releases/2.0/el7/x86_64/foreman-release.rpm
yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.15/katello/el7/x86_64/katello-repos-latest.rpm
yum -y localinstall https://yum.puppet.com/puppet6-release-el-7.noarch.rpm
yum -y install foreman-release-scl

yum repolist
Loaded plugins: ulninfo
repo id repo name
foreman/x86_64 Foreman 2.0
foreman-plugins/x86_64 Foreman plugins 2.0
katello/x86_64 Katello 3.15
katello-candlepin/x86_64 Candlepin: an open source entitlement management system.
katello-pulpcore/x86_64 pulpcore: Fetch, Upload, Organize, and Distribute Software Packages.
ol7_UEKR6/x86_64 Latest Unbreakable Enterprise Kernel Release 6 for Oracle Linux
ol7_developer_EPEL/x86_64 Oracle Linux 7Server EPEL Packages for Development (x86_64)
ol7_latest/x86_64 Oracle Linux 7Server Latest (x86_64)
ol7_optional_latest/x86_64 Oracle Linux 7Server Optional Latest (x86_64)
ol7_software_collections Software Collection Library release 3.0 packages for Oracle Linux 7
ol7_u9_base/x86_64 Oracle Linux 7Server Update 9 installation media copy (x86_64)
pulp/7Server/x86_64 Pulp Community Release
puppet6/x86_64 Puppet 6 Repository el 7 - x86_64

There is no extras repo for OEL 7 so not sure if this is going to be an issue or not.

yum -y update
yum -y install katello

fails with:
–> Finished Dependency Resolution
Error: Package: python-pulp-oid_validation-2.21.3-1.el7.noarch (pulp)
Requires: python-rhsm
Error: Package: pulp-rpm-plugins-2.21.3-1.el7.noarch (pulp)
Requires: python-rhsm >= 1.8.0
Error: Package: katello-debug-3.15.3-1.el7.noarch (katello)
Requires: rh-mongodb34
Error: Package: python-crane-3.3.1-2.el7.noarch (pulp)
Requires: python-rhsm
Error: Package: katello-3.15.3-1.el7.noarch (katello)
Requires: rh-mongodb34
Error: Package: python-pulp-repoauth-2.21.3-1.el7.noarch (pulp)
Requires: python-rhsm

any ideas ?

python-rhsm is not shipped with Oracle. I guess you should use the centos package like:
https://centos.pkgs.org/7/centos-x86_64/python-rhsm-1.19.10-1.el7_4.x86_64.rpm.html

1 Like