Net::Error execution expired during provisioning


I experience a problem with provisioning new machines in Foreman. My OS
is CentOS release 6.6 (Final). Puppet is 3.8.1-1. Foreman is 1.8.2-1
Last time I provisioned a new machine at June 17th. Everything worked
fine. Now when I'm trying to provision a new machine I'm getting the
following error (the short version):

Warning!execution expired

Net::Errorexecution expired
lib/net/dns.rb:36:in rescue in lookup' lib/net/dns.rb:15:inlookup'
lib/net/dns.rb:62:in dns_lookup' lib/net/dns/a_record.rb:27:inconflicts'
lib/net.rb:24:in conflicting?' app/models/concerns/orchestration/dns.rb:125:indns_conflict_detected?'
app/models/concerns/orchestration.rb:48:in valid?' app/models/concerns/orchestration.rb:48:invalid?'
app/models/concerns/foreman/sti.rb:29:in save_with_type' app/controllers/hosts_controller.rb:84:increate'
app/controllers/concerns/application_shared.rb:13:in set_timezone' app/models/concerns/foreman/thread_session.rb:32:inclear_thread'

lib/middleware/catch_json_parse_errors.rb:9:in `call'

I tried different ip-addresses. I know they're free.

When I delete a machine DNS records successfully updated.

Here are some logs from my DNS server:

17-Jun-2015 13:38:10.696 client updating zone 'xxxxx/IN':
adding an RR at 'mongodb' A
17-Jun-2015 13:38:11.136 client updating zone
'': adding an RR at
'' PTR

30-Jun-2015 10:21:56.017 client updating zone
'': deleting rrset at
'' PTR
30-Jun-2015 10:21:56.478 client updating zone
'xxxxxxxxxxxx/IN': deleting rrset at 'mongodb' A

I don't see any errors message in my DNS logs only in foreman/production.log

I did some OS updates between 17th and 30th of June but I cannot see what
could break it.

I'd appreciate any help