New Host can't get past TFTP

Did that come from your configured Installation Medium?

looks like what I must’ve needed the “Preseed Autoinstall cloud-init user data” template for.


I checked the Installation Media area, the Ubuntu mirror points to Index of /ubuntu.

I manipulated the file to point directly to the Ubuntu releases 20.04.6 LTS iso, but it said it can’t find the preconfig stuff still.

Do you have any Ubuntu builds/templates/configs I can view, or determine what the URL is?

Mine has path$version-$arch/, because I’m hosting the installation files locally. I suspect I either read elsewhere or figured out last year what was written (early this year) in that post I linked,

For Debian and Ubuntu prior to 20.04.3, you could use and Foreman would find the required files based on the code name configured for the OS entry. For Ubuntu 20.04.3+, those files are no longer present in the official upstream repositories. Therefore, you have to extract the ISO image and make it accessible for Foreman Server or Smart Proxy Server during provisioning. For example, you can place it in FQDN/pub/installation_media/ubuntu/20.04/.

That post seems like it has all the pieces. It probably makes more sense to read that than to compare what I did for Jammy last year.

Yep, I just stumbled across that myself… thanks for all of your help! I think I’m much closer than I was… now to expand space on my foreman server and get thins hosted locally!

Alright, so a quick recap of happenings last evening/this morning:

Updated the partition table to use the autoinstall one per your suggestion. Additionally, changed User data template to utilize the autoinstall one as well.

I followed the steps listed in Provisioning hosts. When I attempted to boot, I received an error for invalid magic number. The first time I had a difference in size for the iso, so I re-downloaded it… canceled the build, then started the build again and tried again, but same result.

Additionally, I reviewed the templates as mentioned between steps 4 and 5, and looked at my grub.cfg for the server… it seems right, but I could be wrong. It’s for 20.04.6 LTS (since .3 isn’t available from Ubuntu any longer).

now scratch all that… magic number got fixed, then it went back to the red error above.

Finally figured out that it was in a different location based off directory set in Apache’s config for foreman…

but now, getting blue screened and it happens after DHCP completes but doesnt go to TFTP :expressionless:

and now, we have gotten to this part:

but i can run a wget and pull it myself on other servers?