Nothing to boot, failed to load file or directory in discovery

Hi,

I have problems running discovery with katello with PXE boot.
If add a new host, the installation of the os works, but I don't know how
to use the discovery mode installation.

I already configured the katello server as described in this
manual: Foreman :: Plugin Manuals
Katello is working as dns, dhcp, tfptp, realm and discovery proxy. All
other proxy services beside discovery are working great.

But all I get is the error message, that there is nothing to boot.

Katello Version: 1.12.4
Discovery Proxy enabled for network and active in smart proxy overview.

PXE Linux global template:
<%#
kind: PXELinux
name: PXELinux global default
%>

<%# This template has special name (do not change it) and it is used for
booting unknown hosts. %>

DEFAULT menu
PROMPT 0
MENU TITLE PXE Menu
TIMEOUT 200
TOTALTIMEOUT 6000
ONTIMEOUT discovery

LABEL discovery
MENU LABEL Foreman Discovery
MENU DEFAULT
KERNEL boot/fdi-image/vmlinuz0
APPEND initrd=boot/fdi-image/initrd0.img rootflags=loop root=live:/fdi.iso
rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0
rd.lvm=0 rd.bootif=0 rd.neednet=0 rd.debug=1 nomodeset
proxy.url=https://katello.example.com:9090 proxy.type=proxy
IPAPPEND 2

Does anyone of you have an idea whats going wrong? Do you need any more
informations or configs?

I have found the iussue. I had not defined a next-server in the dhcpd
configuration.

ยทยทยท Am Donnerstag, 10. November 2016 11:40:06 UTC+1 schrieb Christian Froestl: > > Hi, > > I have problems running discovery with katello with PXE boot. > If add a new host, the installation of the os works, but I don't know how > to use the discovery mode installation. > > I already configured the katello server as described in this manual: > https://theforeman.org/plugins/foreman_discovery/7.0/index.html#2.Installation > Katello is working as dns, dhcp, tfptp, realm and discovery proxy. All > other proxy services beside discovery are working great. > > But all I get is the error message, that there is nothing to boot. > > Katello Version: 1.12.4 > Discovery Proxy enabled for network and active in smart proxy overview. > > PXE Linux global template: > <%# > kind: PXELinux > name: PXELinux global default > %> > > <%# This template has special name (do not change it) and it is used for > booting unknown hosts. %> > > DEFAULT menu > PROMPT 0 > MENU TITLE PXE Menu > TIMEOUT 200 > TOTALTIMEOUT 6000 > ONTIMEOUT discovery > > LABEL discovery > MENU LABEL Foreman Discovery > MENU DEFAULT > KERNEL boot/fdi-image/vmlinuz0 > APPEND initrd=boot/fdi-image/initrd0.img rootflags=loop root=live:/fdi.iso > rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 > rd.lvm=0 rd.bootif=0 rd.neednet=0 rd.debug=1 nomodeset proxy.url= > https://katello.example.com:9090 proxy.type=proxy > IPAPPEND 2 > > > Does anyone of you have an idea whats going wrong? Do you need any more > informations or configs? >