Openscap Profile Not Found

I have the following configuration.
Foreman_openscap v0.6.7
Foreman v 1.14.3
Foreman-proxy v 1.14.3

I have installed the foreman openscap plugin on a RHEL 7.3 foreman server.
The only issues is that I know cannot get any reports generated when I run
with a template file.

I have created my own template file based on C2S for Red Hat Enterprise
Linux that has the id of
"xccdf_XXX_profile_C2S_RHEL-7.3_Server". From SCAP Workbench I can perform
a scan of my server using the same
profile and template file.

If I run 'crontab -l' I get
/usr/bin/foreman_scap_client 6 > /dev/null

when I run the command '/usr/bin/foreman_scap_client 6' I get the error
DEBUG: running: oscap xccdf eval --profile
xccdf_XXX_profile_C2S_RHEL-7.3_Server --results-arf
profile "xccdf_XXX_profile_C2S_RHEL7.3_Server" was not found. Get available
profiles using:
$ oscap info

Running the oscap command generates a list of profiles that could be used
but not the one I have listed in /etc/foreman_scap_client/config.yaml

If I go into Foreman and change the SCAP Policy to remove the template file
that I created everything works as advertised (after puppet has run) when I
run the command
"/usr/bin/foreman_scap_client 6" and a report is generated.

The only element that has changed when the command is run is the profile
name the command uses the same xml file.

Can anyone see what am I missing here?

Thanks Barry