Operation too slow. Less than 1000 bytes/sec CentOS 7 Updates from Forman

Hello everyone, I am syncronizing the CentOS 7 repositories to our Foreman/Katello Server and then have CentOS 7 hosts subscribed to it. All packages are installed from the server and that works well.

But each server, that has the java-1.8.0-openjdk package installed, can’t update Java because it claims, that java-1.8.0-openjdk-headless- is available but shows the following error:

https://hostname/pulp/repos/ORG/ENV/CentOS_7_Content/custom/Centos_7/updates_x86_64/Packages/j/java-1.8.0-openjdk-headless- [Errno 12] Timeout on …

if I check in the UI, I can see the package in the correct repository.

What could be the issue? How can I troubleshoot that? The servers are in the same network, there is no firewall or content filter in between.


Try using curl or wget with that URL to see if you can download the RPM…

1 Like

Many thanks. I did try with wget, but I gut a 404. I researched the location on the server and saw a symlink, that was pointing into the air. I have changed the download policy from on demand to immediately, then It worked. I can keep it this way.

1 Like

By default the pulp backend should download files on the fly. I am not sure how it works tho, there should probably not be any broken symlinks. Maybe the file did not download from the upstream server correctly. Anyway, immediate will pre-download all the content for you if you don’t mind the size. That will work for sure.

A few days ago I had issues with a few rpms which were not available for download through the proxy. Metadata was also not completely up to date for all repositories. I ran a complete sync on the smart proxy and after that everything was working again.