PLP0009 error on content view publish

Attempted to publish a new version of a content view with all the same attributes as the previous one to get rid of any older packages no longer in the repos. The publish failed almost immediately with 2021-12-08T15:50:37 [E|bac|] PLP0009: Missing resource(s): repo_id=1-contentviewname-v6_0-a8fe515c-ed01-4278-8872-d064f359496f (Katello::Errors::PulpError) undefined method []' for nil:NilClass 2021-12-08T15:50:37 [E|bac|] PLP0009: Missing resource(s): repo_id=1-contentviewname-v6_0-bda94918-3efb-405f-80a5-ece368ed5c12 (Katello::Errors::PulpError) undefined method ’ for nil:NilClass
Task is now paused. Attempts to resume fail and it goes back to being paused.

Expected outcome:
New version 6 of content view should complete publishing.

Foreman and Proxy versions:
Foreman 2.2.3-1 and foreman-proxy 2.2.3-1

Foreman and Proxy plugin versions:

Distribution and version:
CentOS Linux release 7.9.2009 (Core)

Other relevant data:
Not sure if the repo_id=1 matches the repo_id from hammer repository list command. Tried doing a ‘verify content’ sync for the repos, but no change.

Decided to just Force Cancel the task, delete the CV and re-publish. Second time worked fine. No idea what caused the hiccup.