Problem installing Dell Server with Debian

PXE Install can’t find root
Expected outcome:
Debian Install successful
Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Katello 3.18
Distribution and version:
Debian 10.2
Other relevant data:
i’ve got the Debian 10.2 PXE Installation of a VMware VM working. Now i’m trying to get a dell server installed using the same Method.
Adding the nonfree kernel modules to initrd i was able to pxe boot the system.
Now i have the problem that during the kernel boot the kernel module usb_storage is loaded. This module finds a “Dell idrac vflash” card, which i somehow can’t get removed.
i already tried to blacklist this module in the kernel call with “usb_storage.blacklist=yes” and “modprobe.blacklist=usb_storage”. neither of both worked.
analyzing the syslog file on the pxe booted system is saw that foreman tries to use the first disk found to install debian it.
as far as i can see this is happening by running "debconf-set partman-auto/disk “$(list-devices disk | head -n1)”. i couldn’t find this command in any template in foreman.
what i have found is “<%= @host.diskLayout %>” which results in the partman command.

where and how can i either disable the usb_storage module or get foreman to use another (for instance the 2nd ) disk for installing the OS ?


Hi, i see

<% if host_param('install-disk') -%>
d-i partman-auto/disk string <%= host_param('install-disk') %>
<% else -%>

in the “preseed default” partition table template. So i guess, you can configure a different disk by setting the install-disk as a host parameter.


in my preseed default i can’t find this entry.
which foreman version are you using ?
This is “kind of” what i was looking for.


Hi, this is in my preseed default regarding install-disk:

<% if host_param(‘install-disk’) -%>
d-i grub-installer/bootdev string <%= host_param(‘install-disk’) %>
<% elsif ( == ‘Debian’ and @host.operatingsystem.major.to_i >= 8) or ( == ‘Ubuntu’ and @host.operatingsystem.major.to_i >= 16) -%>
d-i grub-installer/bootdev string default
<% end -%>

i found it and the install is running fine.
simply setting install-disk to /dev/sdb as a host parameter solved the problem.

nevertheless, does anyone know, how to disable usb_storage for pxe install ?

1 Like