Problem with foreman-proxy-certs-generate - UnicodeEncodeError

After initial installation of Foreman/Katello on a new Rocky 8 server I have running into an issue trying to generate the certs to add a smart proxy. The foreman-proxy-certs-generate command keeps generating the following errors:

Rotated: katello-server-openssl.cnf → katello-server-openssl.cnf.1

Traceback (most recent call last):
File “/bin/katello-ssl-tool”, line 11, in
load_entry_point(‘Katello-Certs-Tools==2.9.0’, ‘console_scripts’, ‘katello-ssl-tool’)()
File “/usr/lib/python3.6/site-packages/katello_certs_tools/”, line 955, in main
File “/usr/lib/python3.6/site-packages/katello_certs_tools/”, line 921, in _main
genServerCertReq(DEFS, options.verbose)
File “/usr/lib/python3.6/site-packages/katello_certs_tools/”, line 405, in genServerCertReq, caYN=0, verbosity=verbosity)
File “/usr/lib/python3.6/site-packages/katello_certs_tools/”, line 730, in save
UnicodeEncodeError: ‘ascii’ codec can’t encode characters in position 607-609: ordinal not in range(128)

Expected outcome:
The certs tar bundle for the new Smart Proxy is successfully generated to use in installing the new Smart Proxy

Foreman and Proxy versions:
Foreman 3.6.1 / Katello 4.8.1
Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:
Everything else about the installation is working fine. I have added content, created content views, added a couple RHEL subscriptions, registered some hosts, etc.

As a follow up for this - I happened to have a Lab Foreman/Katello server still sitting around from the little POC we’d done. The foreman-proxy-certs-generate worked fine on that so I starting digging through some debug data between the functional and broken systems. The only thing that I could find was on the broken system one of the katello-ssl-tool commands used a value of “” for the --set-org parameter while the one that worked use a value of without the quotation marks. Comparing the value of between the two with “hammer organization list” they appeared to be the same. But the broken system would always fail on the katello-ssl-tool command where had quotations around it. As we had not gotten very far into the setup of the new system we just wiped it, ran the Foreman/Katello install again. After the reinstall the foreman-proxy-certs-generate worked just fine.