Problems executing provisioning template in EC2

> I'm having a problem provisioning all EC2 servers, and can't find what
> the problem is. I created the compute resources successfully, and the
> instance launches successfully, but I receive the following an error
> – … I also tried recreating the
> compute resource, and tried with multiple new hosts to no avail. The
> debug messages that seem the most interesting are:
> 1.
> connecting to ssh-agent
> 2.
> could not connect to ssh-agent
> I retrieved the private key from the key_pairs table (also verified
> the sql is calling the correct one), and was able to ssh in just fine.
> I did receive the following warning when sshing to the IP rather than
> the hostname, although I'm unsure if that would cause a problem:
> > Address maps to
>, but this does not map back to
> Additionally, I wrote a small ruby script to reproduce, but wasn't
> able to. The script I wrote is:
> require 'rubygems'
> require 'net/ssh'
> keys = ["~/id_rsa"]
> Net::SSH.start('', 'root', :keys => keys, :verbose =>
> :debug) do |ssh|
> # do nothing
> end
> and it gave me this output:
> Notice how it uses the same
> key (35:97:c3:25:6b:e1:46:6d:f5:e7:dd:d7:c3:2b:26:2a), but succeeds
> this time.
> I'm on Centos 6.3, using foreman-1.0.0-0.6.el6.noarch from the foreman
> repo
> Any help would be appreciated.

Are you sure the ami you try to ssh to allows root user login?
Any chance you can grab the instance logs?


··· On 07/14/2012 10:02 PM, Joshua Braegger wrote: > -- > You received this message because you are subscribed to the Google > Groups "Foreman users" group. > To view this discussion on the web visit > > To post to this group, send email to > To unsubscribe from this group, send email to > > For more options, visit this group at >