Problems importing classes nekototori/winrmssl

I’m trying to enable and setup WinRM over HTTPS on my windows 7-10 hosts.
I installed and distributed windows_puppet_certificates and now I’m trying to add nekototori/winrmssl to complete the configuration.

Expected outcome:
I imported the module using sudo puppet module install nekototori-winrmssl --version 2.0.1 and the module successfully installs. I run import environment classes in foreman but the module is not added.

Foreman and Proxy versions:
Proxy version 2.0.3

Distribution and version:
Debian 10

The module provides only a new custom type definition no class, so I copy more or less a answer I have given some days for a similar module.

With type definition you get the possibility to define resources, so in this case the module “nekototori-winrmssl” enables you to define “winrmssl” resources.

To define this resources you will need to write your own puppet code or take a module which does this, but without a class structure around this module there is nothing Foreman can present to you in the frontend or your puppet as ENC.

The same problem exists if a module does not provide a class but a defined type which is nearly the same but written in Puppet syntax instead of Ruby.

1 Like

Thank you Dirk,
solved by adding a class to the module.