Problems using Forklift

Doing some development against the API and wanted a way to quickly turn-up different versions of Foreman, so the forklift tool seemed the obvious solution.

I cannot get it to work. Ansible always fails when installing the Puppet repo, but I cannot see why.

TASK [puppet_repositories : Include RedHat] ************************************
fatal: [centos7-foreman-3.2]: FAILED! => changed=false 
  module_stderr: |-
    Shared connection to closed.
  module_stdout: ''
  msg: |-
    See stdout/stderr for the exact error
  rc: 0

I’ve tried Centos7, centos8 & debian - all with the same failure.

Is this a problem with my local Ansible setup?

It’s an ansible version thing. The docs say ansible 2.9+ is required, but that’s clearly out of date. Upgraded to 2.13.7 and it worked.

1 Like

Thanks @agriff79 ,

I’ve opened Update by wbclark · Pull Request #1642 · theforeman/forklift · GitHub to try to keep the README for forklift a bit more current

BTW, to get more useful output when issues like this are occuring, it can be helpful to add the verbose: true flag in your box definition (usually in vagrant/boxes.d/99-local.yaml) like so:

  verbose: true

Please let us know if you have any more feedback about Forklift, and happy developing

Kind regards,