Provisioning failed with 500 Internal Server Error

Foreman Nightly distribution. Bare Metal deploy fails with 500 Internal Server Error.

could you share the production.log and proxy.log? that would likely have further clues as to what failed. You could also try previewing the provisioning template for the host to make sure it renders properly.

Kickstart default is not correctly rendering becouse of that:

ERF22-6132 [Foreman::Renderer::Errors::SyntaxError]: Syntax error occurred while parsing the template kickstart_ifcfg_generic_interface, make sure you have all ERB tags properly closed and the Ruby syntax is valid. The Ruby error: (string):38 :: parse error on value [“end”, 38] (kEND)

can you share the content of kickstart_ifcfg_generic_interface template? looks like there is some error in it

That’s the default one, by the way.
Renamed to *log to accomplish uploads restriction.
kickstart_ifcfg_generic_interface.erb.log (2.0 KB)

hmm… this is a bit of a long shot, but can you try changing line 28 to

<%=   "DOMAIN=\"#{@interface.domain}\"" %>

same error.

Ah! this is Bug #27578: Syntax error in kickstart_ifcfg_generic_interface template - Foreman and is fixed by:

Should be already resolved on 1.23. Why is it still present on 1.24 release?

Errors still:

There was an error rendering the Kickstart Comifar default template: ERF42-7327 [Foreman::Exception]: The snippet 'kickstart_ifcfg_generic_interface' threw an error: Safemode doesn't allow to access 'index' on #<Safemode::ScopeObject>

not sure why the change wasn’t present on your system, but it looks like for some reason the template wasn’t upgraded. which nightly version are you on?
can you paste the template now after the change you made? you can simply paste it in the post and use the “preformatted text” button in the toolbar so it is properly displayed.

Ok, that seems to be solved now. Was a little glitch with template update.