Provisioning fix 25473, what release is it going to be included?


Expected outcome:

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)


Looking at the report on redmine, it looks like the original reporter missed a foreman-rake db:migrate command, possibly when upgrading, which led to the error.,

If you are seeing a similar error, try running foreman-rake db:migrate as well and see if it fixes the issue or not. The migration itself was added in katello 3.8.1, so if you are on an older version you should upgrade.
Also, in the future - please provide more information regarding what you are trying to do, what you are seeing and what versions you are using to help us help you.

I am going a brand new clean install of foreman1.20.2 on am new install of centos 7.6 on a VM.
I am trying to setup the smartproxy service.
I run the generated script to create the dhcp server.
I then get the error message about the extra prameter.

I’m confused - the issue number you mentioned has nothing to do with extra parameters or smart proxy dhcp module.
What commands are you running? What error messages are you seeing?

Went back and made sure I was reading the bug on line correctly.

Bug #25734: wrong number of arguments (given 1, expected 0) - foreman_setup - Foreman

This is what found.

I have dulicated this problem in build 1.20.2
I was looking for the release that had the fix for it by included. Hoping for 1.21

I am creating a new VM with centos 7.6 and the installing foreman 1.20.2 it installs fine with no errors. Using the web menus I add a subnet and the go to provisioning setup and proceeded setting up the provisioning. I choose the network I ant yo use and CLI submit. It generates a script to the screen which I select and copy the script with dhcp I then run from a root shell. It runs to completion without errors.
I then click on the next button in the web gui and get the error message “wrong number of arguments (given 1,expected 0)”

Ah - that explains the confusion, there was a typo in your original message issue number.
There is currently no new version of the foreman-setup plugin that includes the change. You could however manually patch the code on your instance - it is a one-line change, and the file should be at
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_setup-6.0.0/app/controllers/foreman_setup/provisioners_controller.rb on your server. once you patch it, restart apache to make the change come into effect.