Provisioning Setup Errors

Problem: Infrastructure | Provisioning Setup shows 2/3 errors.

  1. Missing registered host, please ensure it is checking in
  2. (Working) Found registered smart proxy
  3. No network interfaces listed in $interfaces fact

Expected outcome: Being able to complete the provisioning setup

Foreman and Proxy versions: 1.17

Foreman and Proxy plugin versions: foreman_setup v6.0.0

Other relevant data:
Base: CentOS 7.4.1708 updated
Roles: DHCP, tftp, etc
Is NOT: DNS, done by a Windows server on a different subnet with the forward and reverse dns entries made and seemingly working

This is a brand new fresh install, nothing else configured within the Web GUI except I have setup a single domain and created a single subnet. Via terminal I opened required ports in firewall and confirmed dhcp conf settings (a client machine was able to get an IP during PXE boot). I have no hosts setup, no compute resourse, etc.

I tried searching the forums and google regarding both messages and generally most people resolved the problem with a reboot, which I have tried roughly 3 times already.

I have confirmed via hostname -f that my hostname is correct and on the expected domain. My /etc/hosts is a single line: foreman

Any help would be great. Thanks

After about half an hour this resolved itself, so I guess the moral of the story is reboot and be patient. Thanks