Puppet autosign not working


I'm struggling to get puppet autosign working for hosts provisioned by

I'm running 1.8.2 on CentOS 7. I have a separate puppetca server, which
has a smart-proxy on it. I'm provisioning hosts via pxe discovery.

I can add and delete autosign entries within the gui and these are
correctly reflected in the /etc/puppet/autosign.conf file.

However, when I provision a new host, within a hostgroup which has the
puppetca smart proxy set, I see no entries in the foreman logs suggesting
that it is posting to the puppetca proxy to add the hostname to the
autosign.conf file. There are also no entries in the puppetca proxy to
show any posts coming from foreman.

I've got everything else working a treat so far, just this autosign part
which is eluding me.

Is there some config setting I'm missing which is preventing this from


I can't believe I missed the setting. On the provisioning tab:
manage_puppetca: false
I looked at those pages about 5 times…

Sorry for the spam. It's working fine now, surprisingly.