Puppet cert clean NAME loads CPU 100% and prints a lot of lines: Revoked certificate with serial NUM

Hi all,

I am facing issue with foreman 1.12. Puppet version is 3.8.7, OS: RHEL 6.8.

The issue is when the host is trying download kickstart when it is
reprovisioned and host reach dracut timeout and reprovisioning fails.

On puppet CA proxy I can see that process puppet is loading CPU about
90-100% . seems that it tries run:
/usr/bin/sudo -S /usr/bin/puppet cert --ssldir /var/lib/puppet/ssl --clean

and it takes some time…

When I tried run this command manually, console prints a lot of lines one
by one like this below:
Notice: Revoked certificate with serial NUM
where NUM is different each line.

I found similar issue here:

So I've ran command:
puppet cert reinventory

Which seems also helped for me. But each time, when I run puppet cert clean
cert-name and generate the new one, the new line with revoked
certificate with serial appears.
So my problem probably will appear again when the host will be multiple
time provisioned.

Anyone face the same issue, or can help with it?

Thanks, Petr