Puppetdb fails to install


#1

I’m trying to add puppetdb to our foreman installation. The puppetrun fails.

Puppetdb up and running

Foreman 1.20.2, Proxy version 1.20.2

Tried most recent puppetdb module 7.1.0 and version 6.0.2

Error: Systemd start for postgresql-9.6 failed!
journalctl log for postgresql-9.6:
-- Logs begin at Wed 2019-05-15 16:39:29 CEST, end at Wed 2019-05-15 16:53:25 CEST. --
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Starting PostgreSQL 9.6 database server...
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: postgresql-9.6.service: main process exited, code=exited, status=1/FAILURE
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Failed to start PostgreSQL 9.6 database server.
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Unit postgresql-9.6.service entered failed state.
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: postgresql-9.6.service failed.

Error: /Stage[main]/Postgresql::Server::Service/Service[postgresqld]/ensure: change from 'stopped' to 'running' failed: Systemd start for postgresql-9.6 failed!
journalctl log for postgresql-9.6:
-- Logs begin at Wed 2019-05-15 16:39:29 CEST, end at Wed 2019-05-15 16:53:25 CEST. --
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Starting PostgreSQL 9.6 database server...
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: postgresql-9.6.service: main process exited, code=exited, status=1/FAILURE
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Failed to start PostgreSQL 9.6 database server.
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: Unit postgresql-9.6.service entered failed state.
May 15 16:53:25 foreman.infosys.ifv.systems systemd[1]: postgresql-9.6.service failed.

Does anyone recognise this problem?