PXE boot not giving the correct server

Problem:
I have foreman set up on a network as DHCP and DNS server with TFTP enabled. the network uses a seperate firewall for internet acces which has DHCP and DNS disabled.
In the dhcp_ics config is the next server set to the foreman server ip and when i look at the dhcpd.leases file i also see the supersede server.nextserver with the foreman server ip adress.

when i try to perform a PXE boot however the booting device gives an ip adress in the 49.48.x.x range instead of the 10.10.x.x adress that’s been configured

Expected outcome:
that the machine using PXE boot has the foreman server as next server so it will continue the PXE boot

Foreman and Proxy versions:
Version 2.4.1

Distribution and version:
Foreman is running on Debian 10.10

Can you double check there is just this single DHCP server on this network? Also grep next-server directive in the whole DHCP config directory.

i’ve double checked and at the moment theres only the foreman server, the firewall and the machine i try to pxe boot on the network. the firewall has dhcp disabled.

when i do a grep on next server for the whole DHCP config directory i only get the foreman server returned

Do you see that IP in the DHCP reply when looking using wireshark/tcpdump? Really strange.

From my experience: you are running a second DHCP server. I’ve seen this few dozens of times :slight_smile: You need to rule this out, check client logs not server logs because both DHCP server will reply however the client decides which response to use. Or use wireshark etc.

Also restart the server to squash dhcpd.leases file to really see what’s in there.

FYI Foreman always configure the supersede option, so for reserved hosts the configuration in dhcpd.conf is irrelevant (it is only used for unknown hosts).

Hello Izap,

since there are no other devices besides the firewall, foreman server and machine to pxe boot i have tried turning off the foreman server and coming to the conclusion that there is not other dhcp server at work as i then get a message from the pxe that there are no configuration methods are available as no dhcp server is found.

in case anyone else will come across this problem. in my case it seems to have been due to an incorrect value for the --foreman-proxy-dns-reverse option. I changed that and since then it behaves as expected