PXE booting a Virtual Machine Using Foreman

Problem: Getting Could Not Resolve HostName foreman.example.com error while PXE booting a Virtual Machine . How can this be resolved .

Expected outcome: When is replace the Name with I.P in PXEBoot file of the VM on Foreman Host . It works. How

**Foreman and Proxy versions:**foreman-1.11.4 and foreman-proxy-1.11.4

Foreman and Proxy plugin versions:

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)

curl: Could not resolve host: foreman.example.com; Unknown error 
Warning : Anaconda failed to fetach kickstart from http://foreman.example.com/unattended/provision?token


first off, are you really using Foreman 1.11? That release is several years old by now and will have a lot of bugs and missing features compared to the current version. I assume you have just started with Foreman so I strongly recommend upgrading. Most people will not have such an old version running anymore and will probably not be able to help you with most problems you might encounter.
The current stable release is 1.23 (just release some days ago).

For your problem, the easiest solution would be to set the nameserver via DHCP so that the systems have setup DNS right from the start. If that is not an option for you (e.g. because you have no DNS setup for whatever reason) the should be a “foreman url” option in the setting (in the UI somewhere under Administer -> Settings). I think changing that to the IP of your system should also change the PXEBoot file.




Thanks you very much for the solution provided. I am surprise that i am using CentOS Linux release 7.5.1804 (Core) on foreman server and it is providing the old version of foreman. Can you please suggest me the link how can i upgarde foreman to new version.

Also after the above error resolved now i am getting different error of no space left on device during pxe But there is 8 GB virtual disk assigned to VM and Foreman server also has lot of space. Dont know why this error is coming. Please help me. Many Thanks

PXE boot installation is successfull now. I realized that i need to increase the RAM from 1GB to 1.5 GB and it works now! .

Can you please suggest me the link how can i upgarde foreman to new version.

The official installation guide can be found here: Foreman :: Manual
I have to admitt, installing Foreman can be very confusing the first time. There are a lot of options you can choose and combine depending on your needs. If you have specific questions, it would probably be best to start a new thread for those. That will give them better visibility to people who are able to help you with those :slight_smile:
I would suggest start from scratch once more, since you just started out and upgrading from such an old release will probably take ase much time.

I’m glad you hear you figured out where the problem was!

1 Like

Thanks areyus. I created new thread but no reply so sending here as well.

Problem: No DHCP and DNS Service installed after i run foreman-installer with version 1.23
Earlier i use foreman 1.11 and it installed default all services DNS and DHCP and all setup was preready.

Expected outcome: All services like DNS, DHCP should be installed by default. How can i install them now after this step.

Foreman and Proxy versions: foreman-1.23.0-1.el7.noarch and foreman-proxy-1.23.0-1.el7.noarch

Foreman and Proxy plugin versions: