Repositories are not listing

Problem: I managed to successfully register the server with the Katello Foreman but the repositories are listing

Expected outcome: package update using the registered Centos 7 repository

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:
subscription-manager identity
system identity: 3c3befb8-621e-4f6c-b62d-43e68291c7bf
name: centos-test
org name: TELE2
org ID: Tele2
environment name: Non_Prod/CentOS_CView

subscription-manager list --available
No available subscription pools to list

subscription-manager repos --enable CentOS7
This system has no repositories available through subscriptions.

subscription-manager list --consumed
±------------------------------------------+
Consumed Subscriptions
±------------------------------------------+
Subscription Name: CentOS7
Provides: CentOS7
SKU: 621480546693
Contract:
Account:
Serial: 3338758334313723073
Pool ID: 8a1c458876dbe3f00176e1a31c300043
Provides Management: No
Active: True
Quantity Used: 1
Service Type:
Roles:
Service Level:
Usage:
Add-ons:
Status Details: Subscription is current
Subscription Type: Standard
Starts: 08/01/21
Ends: 01/12/49
Entitlement Type: Physical

subscription-manager repos
This system has no repositories available through subscriptions.

Please help to resolve the issue.

Thanks.

Adding some more logs.

subscription-manager:32331:MainThread @connection.py:905 - Connection built: host=linuxrepo.com port=443 handler=/rhsm auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2021-01-10 16:33:34,053 [INFO] rhsmd:32343:MainThread @connection.py:905 - Connection built: host=linuxrepo.com port=443 handler=/rhsm auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False

Hello @tbrisker,

Can you please advise me on this.

Thanks.

What about the obvious questions:

Does your product “CentOS7” contain repositories?

Does the content view “CentOS_CView” contain repositories of product “CentOS7”?

Did you publish a version of content view “CentOS_CView” containing those repositories?

Did you promote the published version of content view “CentOS_CView” into environment “Non_Prod”?

Hello @gvde,

Thanks for your update.

Does your product “CentOS7” contain repositories? Yes

Does the content view “CentOS_CView” contain repositories of product “CentOS7”? Yes

Did you publish a version of content view “CentOS_CView” containing those repositories? Yes

Did you promote the published version of content view “CentOS_CView” into environment “Non_Prod”? Yes

I did not mention the katello/foreman version you have installed…

Could you show those “yes” answers with hammer commands? Unless it’s a bug one of those “yes” must be in fact a “no”, so to verified it would be helpful if you would show that…

1 Like