"Run Puppet Once" stopped working after adding plugin

My install had no issues using “Run Puppet Once” untill I ran the foreman-installer to add the EC2 compute resource. Now every time I run puppet from Foreman I get:

/var/tmp/foreman-ssh-cmd-11612e81-1b6e-4758-b2b4-9d66a4117d63/script: line 1: puppet: command not found

When I run puppet agent -test from any host on the Command line it works

# /opt/puppetlabs/bin/puppet agent --test
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Retrieving locales
Info: Loading facts
Info: Caching catalog for foremand-server
Info: Applying configuration version '1590775505'
Notice: Applied catalog in 0.25 seconds

Expected outcome:
Puppet should be able to run from the foreman UI as it did before adding a plugin

Foreman and Proxy versions:
Single instance on version 2.0
Foreman and Proxy plugin versions:
foreman-tasks - 1.1.1
foreman_openscap - 3.0.0
foreman_remote_execution - 3.2.1
katello -

Distribution and version:
Centos 7.8

I started afresh. Will comment if it happens again.

I did a new installation of Foreman 2.0 and back to where I was before. Run Once gives me this error:

/var/tmp/foreman-ssh-cmd-60823e03-40ff-46aa-8ff5-751a899239ec/script: line 1: puppet: command not found
Exit status: 127