Running preseed process hangs

Problem: When we install Ubuntu 18 on VMs sometimes the running preseed process hangs at 17%. A restart of the system does not bring the solution. The OS boots, but the pressed config is of course missing (in this case Puppet is then not installed). If we restart the build process is working (as I said, sometimes it works, sometimes not). Any ideas what the cause could be?

Expected outcome: It should work or at least prompt the error :slight_smile:

Foreman and Proxy versions: 2.0.0

Foreman and Proxy plugin versions: 2.0.0

Distribution and version: Ubuntu 18.04

I think you need to take this to the debian installer mailing list provising the full preseed script to them.

Also when you say sometimes, could it be network related? When something hangs, it’s typically trying to resolve some hostname. Is there a chance DNS server is not reachable at that moment?

But I agree with @lzap here, this feels more as a debian installer issue.

Just to give feedback (even if there was a long pause). This preseed issue always happened at 17%. It is not related to network issues.
After (I guess a timeout) the VM reboots and you can login. Then you will notice that /sbin/start-stop-daemon is missing entirely. So a lot stuff is not working. But if you copy this file from another VM to this one and run Puppet, everything works again.

Right now I am doing an upgrade marathon from 2.0 → 3.4 to see if the problem disappears. But troubleshooting and asking here for help with this old version seems not fair.
But it is a long journey since the updates are sequential. Also I run into this one Foreman does not start after OS upgrade due to an OS upgrade. But now 3.0 is running and I can continue.

I guess at some point the guy that was setting up Foreman change it to our needs.
Then we never touched the templates we are using again. Could it be possible that we just have to take the new default one and add our changes into this one? Or: Is it required to update the templates from time to time?

The default templates are locked and always updated to the latest versions. If you cloned the default preseed and modified it, it’s always a good idea to compare it to the new default after ugprade and incorporate the changes. This can be tedious process and @lstejskal recently thought about creating audit record for such updates, so one could easily review the changes on every upgrade. For now, the best way is to use git on the Foreman repo to compare the changes between tags. In your case (2.0 → 3.4) I’d though recommend taking the default and start with modifications from scratch unless it was heavily modified.

Good luck with upgrades, let us know how it worked and whether it helped!

I’ve replaced my old Preseed default finish template with the new provided one, since I didn’t see any company related changes in our template we were using and my problem is gone! :tada:

My conclusion here is: Since we never updated Foreman :see_no_evil: I guess something in Ubuntu 18/20 was changed whereby the templates didn’t fit anymore.