SCC plugin issues after update to katello 4.3

Problem 1
it is not possible to add product:
task end with error:

can't write unknown attribute `mirror_on_sync`

mirroring policys have been changed to additive, content only and complete mirroring

Problem 2
sles repositories not syncing
task end with error:

404, message='Not Found', url=URL('')

first -----anonimized-token----- should not be part of URL

Foreman and Proxy plugin versions:
foreman 3.1.1
foreman-tasks 5.2.0
foreman_ansible 7.0.2
foreman_bootdisk 19.0.3
foreman_puppet 2.0.3
foreman_remote_execution 5.0.1
foreman_scc_manager 1.8.16
katello 4.3.0

Distribution and version:
Red Hat Enterprise Linux Server release 7.9 (Maipo)

Hi @mihr ,
we have already fixed that issue, but the package is not yet available in the Katello 4.3 repos. You can get it here:

1 Like

hello nadjaheitmann

you right but only partially
Problem 1 adding new repository has been solved
but Problem 2 synchronizing repos has not been really solved because issue has been changed

repositories have now wrong format in “Upstream URL”
bold marked part of URL is missing:

and strange is that by sync there is different behavior by existing and newly added repositories:

in error message by existing repositories there is repodata/repomd.xml part of URL after token and then there is another -----string-like-token----- (maybe old token?)

404, message='Not Found', url=URL('')

by newly added repository is synchronization URL like configured in Upstream URL and it does not work because it is wrong:

404, message='Not Found', url=URL('')

scc plugin update steps:

foreman-maintain service stop
yum -y update
foreman-maintain service start

and then → content → suse subscription → sync of subscription

Right, I missed that one on the first read, sorry. I will take a look at this. If you find a workaround in the meantime, let me know!

Seems to be a problem with pulp3 and the authentication token. We found a workaround for now, but we will also provide a fix asap.

What you can do in the UI if you have this Upstream URL: token--

Copy the authentication token without the ? and put it into Upstream Authentication Token field. You find it when editing Upstream Authorization.

Delete the authentication token from the Upstream URL such that you have:

This is nasty to do for each repository, but I hope this helps you for now.

1 Like

I used the same workaround and can confirm it is working as intended.

@nadjaheitmann please let us know when you have any kind of fix for that :slight_smile: Thank you!

Oh, and for everyone reading this, please keep in mind that each repository has a different token!

Just had to fix mine again after discovering that :frowning:

@rbremer Working on it. Here is the PR. You can apply the patch and test it if you want :slight_smile:

Here is the link to the PR:

@nadjaheitmann Thank you for providing the PR. I already made the correction in all my repos, so I can’t really test it at the moment. As soon as SUSE adds SP4 of SLES 15, I will let you know if it still doesn’t work.

This PR didn’t make it into K4.4 from what I can see. Is that correct?

No, sorry, still not merged. It is on my to-do-list.

1 Like