Self signed certificate in certificate chain

After trying to install Standalone Puppet master and add it to existing Foreman,
I keep getting this error:

SSL_connect returned=1 errno=0 state=error: certificate verify failed (self signed certificate in certificate chain)

I am doing it by manual:

foreman-installer \
  --no-enable-foreman \
  --no-enable-foreman-cli \
  --no-enable-foreman-plugin-bootdisk \
  --no-enable-foreman-plugin-setup \
  --enable-puppet \
  --puppet-server-ca=false \
  --puppet-server-foreman-url= \
  --enable-foreman-proxy \
  --foreman-proxy-puppetca=false \
  --foreman-proxy-tftp=false \
  --foreman-proxy-foreman-base-url= \ \
  --foreman-proxy-oauth-consumer-key=<key here> \
  --foreman-proxy-oauth-consumer-secret=<secret here>

Foreman has a self signed CA. *

**Expected outcome:no error

**Foreman and Proxy versions:Foreman: Version 1.15.4 Proxy: 2.0.1

OS: CentOS Linux release 7.7.1908

I have copied CA certificate from Foreman to new puppet master directory /etc/pki/ca-trust/source/anchors, run “update-ca-trust”, but no effect.
Can I disable strict certificate checking when running installer?

Is this correct?
Even though it might not the source of the described problem, this is very odd.
Foreman 1.15 can be considered ancient, while proxy 2.0 is the current version.
If those version numbers are correct, please start by installing the corresponding the proxy version for your Foreman version first, since these are most likely not even compatible in any form. For installing the 1.15 smartproxy, also remember to use the documentation for 1.15, since the installer commands have also changed over time.
Also, I strongly recommend updating your Foreman server as soon as possible to a recent version. The Foreman community usually always supports the latest 2 releases. This will also increase the likelyhood of people on the forum beeing able to help with future problems, since about noone will have such an old version of Foreman around to test and help with problems.