Server discovery url/ip

I’ve got a server which is mutlihome with :

  • on public IP
  • one IP on a non routed network, which will be my “installation LAN”, this is this LAN wher PXE/tftp and so on will go,
    when booting another server in PXE, the DHCP/PXE/discovery image is loaded OK, but all the results cannot be send as the “discovery URL” is the public one which is unreachable.
    I’ve not found anyway to modify this in foreman ?
    find that it was set in the tftp server default.cfg, so change it there the hard way… got a connection but got a “404 error”, page not found !

what shoyuld I do to have this configuration working ? what did I missed ?
Expected outcome:
a working PXE discovery !

Foreman and Proxy versions:

Distribution and version:

Maybe @lzap can tell, but I’m guessing there isn’t anything stopping you from setting the IP address in the discovery URL.

That, or give the public IP a different name (or internal) and update DNS/Foreman accordingly :slight_smile:

This should be configurable in the default PXE provisioning template.
What you want to focus on is the discovery image kernel parameter called proxy.url

Please, refer to the 3.1.5 Discovery image kernel options chapter of the Foreman Discovery manual

(Sorry if I misunderstood the problem statement)