SSH User for Finish Scripts

provisioning

#1

Problem:
Prior to 1.22, ssh for finish provisioning scripts were using a different user name (‘administrator’) instead of the default ‘root’ user.

Expected outcome:
Should be able to set the ssh user for finish scripts but the option seems to be gone.

Foreman and Proxy versions:
1.22

Foreman and Proxy plugin versions:
1.22

Other relevant data:
Used to work in versions prior to 1.22.


Release meeting notes 2019-06-12
#2

Same problem here.
After update to 1.22 ansible plugin/rex stop working using another user other than root.


#4

There was a question if there’s a setting to disable auto-deletion of VM in case ssh connection fails. Yes, there’s is “Clean up failed deployment” in Settings -> Provisioning that can be used. The user is set on image level, can you double check you have custom user configured for this image? If not, please upload logs, you should be able to find a message similar to “Failed to login via SSH to $name”


#5

I deleted my question because I found the setting and set it to false. So now I can still provision new vms. Thank you for your help!


#6

Thank you!!! I updated the passwords in the images and now ssh is working!!!