SSL Errors After Puppet Upgrade

Hello Everybody!

We’re attempting to upgrade our Foreman / Katello installation from 1.14 to 1.15 and Puppet 4 - all on our way to 1.16. We first followed the upgrade steps located at /plugins/katello/3.4/upgrade/ and everything was going swimmingly. We then attempted to upgrade Puppet to version 4.

However, following the instructions found at Foreman :: Plugin Manuals resulted in Puppet clients dumping the error:

puppet agent --test
Error 500 /etc/puppetlabs/puppet/noderb returned 1

Looking at the logs in /var/log/foreman/production.log gives the error:
SSL cewrt has not been verified
Completed 403 forbidden

I verified the paths in the various conf files and they appear to be correct.

I then tried resetting the certificates and running the Foreman upgrade steps found at Upgrading from Puppet 3 to 4 - Foreman with the same results.

I also tried re-installing the Katello-client-ca RPMs. subscription-manager and yum appear to work correctly but Puppet still produces 503 errors.

Any suggestions would be greatly appreciated!