Subscription not shown on host

A specific new Subscription does not show up on hosts. subscription-manager list --available/consumed shows every subscription except the desired one.

Expected outcome:
Subscription shows up on host, yum sees repo and packages are available for install.

Foreman and Proxy versions:
Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:
All other Subscriptions work fine. For testing I did the following again:
-Added new product
-Added repo (without upstream,packages are provided only via hammer-cli)
-Added new CV with the new repo
-Added CV to a CCV and promoted ned version to testing environment
-Added subscription to activation key
-Subscribed ost again with this key

Now the content host got the subscription (repo in repository set enabled) all good. But on the host it sees every subscription and repo it should except the desired one. Also the correct environment and org. is set ( subscription-manager identity).

What did I miss, where could I check next?


could you please check if you are affected by this problem? It reminds me of that issue a lot.
I’m not sure if that is fixed in your Katello version already (target versoin in Bugzilla is 3.15, so probably not since that is not released yet). The Problem is that Katello generates Certificates that last for 30 years by default, and since 2020 this kills some python SSL library used in subscription-manager.
The easiest way is to check if the subscriptions for your newly generated products have an end date of greater than 31.12.2049.


1 Like

Hi areyus,

thanks very much! Thats exactly what I needed!
I dunno why I didn’t find anything to that here/via google with my keywords… hopefully somebody else can use this post in the future.


Glad it worked :slight_smile:
Yeah, searching this problem is a little hard and there are few reports about it.
Since your issue is solved, could you please mark the thread as solved? Use the checkbox icon on the appropriate answer for that, this way people who might stumble across this thread know it has been solved :slight_smile:

1 Like