Tip: websocket SSL issue with vnc (alternative solution)

Hi all,

The Foreman 1.9 documentation specify to turn off websocket ssl
security in web browsers (see:
Foreman :: Manual).

IMHO a better approach should be to suggest importing puppet CA in web browser.

Download /var/lib/puppet/ssl/certs/ca.pem somewhere in your $HOME.
For Firefox :

  • Choose Preferences from the Edit menu.
  • Click the Advanced button.
  • Select the Encryption pane.
  • Click the View Certificates button.
  • Click the Authorities tab.
  • Click the Import button at the bottom of the screen and select
    ca.pem you just download.

Maybe the doc should be updated in that sense.

Best regards