Trying to install signed certificate

Problem. Running foreman-installer --scenario katello --certs-server-cert /root/sat_cert/satellte_cert.pem --certs-server-key /root/sat_cert/satellite_cert_key.pem --certs-server-ca-cert /root/sat_cert/Bundle.crt --certs-update-server --certs-update-server-ca keeps failing with pulpcore-manager migrate --noinput returned 1 instead of 0. Not sure what is wrong. Looking at the katello.log file did not help much. Any ideas?

Expected outcome: Command runs without errors.

Foreman and Proxy versions: 2.3.3-1

Foreman and Proxy plugin versions: Katello 3.18.2-1

Distribution and version: CentOS 7.9

Other relevant data: This is on a fresh install. I just kickstarted and started the installation.

Hi @bradawk
Sorry for the late reply.
Did you get any further with this or is it still outstanding?

No. It still fails. I was hoping someone here would tell me that I was doing wrong. :slight_smile:
Are the versions of foreman and katello I’m trying to use compatible? When I tried to install with foreman 2.4, things failed very quickly. So, I moved back to this version. Maybe I need to roll back a little more?
It is hard to find any document that states what versions of katello require what versions of foreman.

Can I ask why they are labelled Satellite?
Did you use those docs?

This probably needs fixing but night not be the cause of your issue.

Not sure. I put together my documentation when I was running a Red Hat satellite server. I modified it when I had to convert to open source applications.
However, I have another satellite server that the command worked fine on. It has been working every time I’ve re-installed. Just this time it is not. I guess I could re-kick it again on Monday and see if it fails again at the same point?

Not sure what changed? I rebooted the server and then ran the exact same command. This time it succeeded. Very strange. We can close this. Thanks for taking a look! :slight_smile:

1 Like